Symptoms:

 

After performing a VPG Failover Test, when the test is stopped one or more VMs are not removed cleanly from the VMware environment. When you try to manually delete the VM from vCentre the option to 'Delete' is greyed out.



Cause:

 

When Zerto creates a VM as part of an automated process it locks the VM ensuring only Zerto components can control the associated VM/s



Solution:


  1. Download the attached EnableVM.zip file to the ZVR directory off  the affected ZVM
  2. Extract the archive
  3. Run it as follows, where 'VM moref' is e.g. vm-123
    EnableVM <VC IP> < VCadmin user> <VM moref>
  4. The tool will ask you for the password with which to connect to the vCenter, and it should then unblock the VM.
  5. If you use vCloud Director you may also need to force delete any associated vApps created by the failover test.



In order to match the VM name to its MoRef ID 

  1. Navigate to https://vcenterIP/mob
  2. Login with admin credentials
  3. Click the "Content" link under the value for the "content" property 
  4. Click the "group" link under the value for the "rootFolder" property 
  5. Click the relevant "datacenter" link under the value for the "childEntity" property 
  6. Click the relevant "group" link under the value for the "hostFolder" property 
  7. Click the "domain" link for the relevant cluster (or standalone host) under the value for the "childEntity" property 
  8. Check the values for the "host" property - the relevant hosts will be listed there along with their MoRefs