The DS-Client is in standby mode because the database number does not match with the one required by the service!

Modified on Tue, 31 Oct 2023 at 11:23 AM

Symptoms


The error message pops-up after passing the DS-User logon screen.

 

Cause


a) The dsclient database cannot be accessed by the DS-Client service account ( for example the SQL Server instance is stopped or the DS-Client service account has been changed to a user without sysadmin permissions ).


b) The DS-Client database patch number does not match with the one required by DS-Client binary.


c) The registry value ( on the DS-Client computer ) for HKLM\Software\Asigra\DS-Client\\hotfix does not match with the value of DSC_High_Ver from Setup table ( dsclient database ), for example the registry value for HKLM\Software\Asigra\DS-Client\13.1.0\hotfix is 0 while the value for "DSC_High_Ver" from "Setup" table is 13.1.2.5 instead of  13.1.2.0 


d) Windows DS-Client uses embedded PostgreSQL and the corresponding service DS-Client-PostgreSQL is not started or does not accept connections (in this latter case an error like 'Incompatible Lanfiles database (4, -1)' may be also logged in Windows event viewer application log).


Workaround


a) Ensure the SQL Server instance holding the DS-Client databases is up and running and that the DS-Client service account has sysadmin role assigned. Check the operating system event viewer / application log on the DS-Client computer for details on why the connection to the database fails.


b) ensure the dsclient database patch number matches the one required by DS-Client binary. At the time this error is reported an entry is also logged in the operating system event viewer / application log on the DS-Client computer specifying the required and the actual database patch number. Alternatively you can retrieve the database patch number by connecting with SQL Management Studio or sql tools to the SQL Server instance holding the DS-Client databases and running the following query on the dsclient database: select db_number from setup; The easiest way to apply a missing patch is to re-run the package that caused the problem ( e.g. main release installer if the issue occurred right after trying to upgrade to a higher main release, or the service pack or even only the hot fix that caused the mismatch ).


c)

- stop DS-Client service;

- ensure the registry hot fix level and the DSC_High_Ver database value match, for example if the registry value for HKLM\Software\Asigra\DS-Client\13.1.0\hotfix is 0 you can identify the value for DSC_High_Ver by connecting with SQL Management Studio or sql tools to the SQL Server instance holding the DS-Client databases and running the following query on the dsclient database:


select DSC_High_Ver from setup;


if the returned value is for example  13.1.2.5  instead of the correct one  13.1.2.0  you can update it with the following query:


update setup set DSC_High_Ver='13.1.2.0';


Once the change done, start back the DS-Client service.

In most cases if DS-Client database patches cannot be applied with a hot fix or service pack is because the current logon Windows user (on DS-Client computer) does not have rights to connect to the SQL Server instance holding the DS-Client databases, one quick solution is to check in Start > Administrative Tools > Services what is the "DS-Client" service account, then logon in Windows (on DS-Client computer) with that account and apply the hot fix one more time.


d) Ensure that the DS-Client-PostgreSQL service is started, then restart the DS-Client service. If the issue is still not resolved even if both services are up and running, open a support case.

Also, make sure that a concurrent number of backup tasks do not overload the DS-Client server, what can cause some lag in the DB connection. Try to reduce the load.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article