activity stopped: Could not allocate space for database

Modified on Mon, 11 Sep 2023 at 09:39 AM

Symptoms


The error may be reported during a restore or any other activity involving insert operations into dsclient or dsdelta database.


Cause


At the time the error is reported the free space on the volume where one of DS-Client databases ( dsclient, dsdelta, dslanfiles or expand0001, expand0002 ... ) is located went under 5% - this is the emergency level set by default under DS-User > Setup > Configuration > Advanced > Notification > DBEmegencyLevel ( 500 means 5% ).


Workaround


Ensure the free disk space on the volume holding DS-Client databases does not go under 5% at all times. One known reason for such situation is that some backup sets are configured with 'use buffer' option ( In DS-User right-click on the backup set > Properties > options, for Exchange Server backup sets in DS-User > right-click on the backup set > Properties > Database > Dump Location ), thus during backup the data to be protected will be always saved in full to DS-Client buffer first, then processed and sent to DS-System and/or local storage, once the data processed the DS-Client buffer is cleaned ( so the full disk space condition is resolved until the next backup ). By default the path for DS-Client buffer is C:\Windows\Temp, if necessary it can be changed ( via DS-User > Setup > Configuration > Parameters ) to a folder located on a different volume with enough free disk space ( assuming DS-Client databases are located under default SQL Server installation path C:\Program Files\Microsoft SQL Server ).

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