Summary
When installing/upgrading Zerto software on a Windows server, the user receives an MSI error during installation with the code 2147024894. Installation then exits without completing.
Root Cause
Likely scenarios that can cause "MSI Error 2147024894"
1. An incomplete download. The installation media may not have been completely downloaded initially.
2. A user is starting the install while the installation media is still within the zip/compressed file.
3. The Zerto software is being ran while it is not on the ZVM VM.
1. An incomplete download. The installation media may not have been completely downloaded initially.
2. A user is starting the install while the installation media is still within the zip/compressed file.
3. The Zerto software is being ran while it is not on the ZVM VM.
Symptoms
When attempting to run a Zerto upgrade or install the user runs into the following error:
MSI Error 2147024894
MSI Error 2147024894
Solution
Troubleshooting Steps
- Extract the media from the zip/compressed file and re-attempt the install
- Re-download a fresh copy of the installation media from the partner portal and re-attempt the install.
- Open a ticket with AssureStor support