Symptoms:
When performing a move operation on a VPG, the action may fail. In this scenario, the ZVM logs logs will contain the following error:
"Failed applying configuration to VM (ID vm-XXXX) Message: The operation is not allowed in the current state".
Example:
71595675,xxxxxxxx,,,20-02-22 01:01:50.61,E,151,BulkOperationVmQueue,BulkReconfigVmLocked,"Got exception in bulk operations, canceling operation","VCenterConnectionLayer.VMBasicsException Void HandleVMwareFault(System.String, VCenterConnectionLayer.VMwareFaultException) VCenterConnectionLayer.VMBasicsException: Failed applying configuration to VM (ID vm-XXXX) Message: The operation is not allowed in the current state.. Fault: Vim25Api.InvalidState. ---> VCenterConnectionLayer.VMwareFaultException: Exception of type 'VCenterConnectionLayer.VMwareFaultException' was thrown.
"Failed applying configuration to VM (ID vm-XXXX) Message: The operation is not allowed in the current state".
Example:
71595675,xxxxxxxx,,,20-02-22 01:01:50.61,E,151,BulkOperationVmQueue,BulkReconfigVmLocked,"Got exception in bulk operations, canceling operation","VCenterConnectionLayer.VMBasicsException Void HandleVMwareFault(System.String, VCenterConnectionLayer.VMwareFaultException) VCenterConnectionLayer.VMBasicsException: Failed applying configuration to VM (ID vm-XXXX) Message: The operation is not allowed in the current state.. Fault: Vim25Api.InvalidState. ---> VCenterConnectionLayer.VMwareFaultException: Exception of type 'VCenterConnectionLayer.VMwareFaultException' was thrown.
Cause:
This issue occurs if the vCenter management agents have stopped working properly, causing the VM move attempt to fail in the ON_SHUTTING_DOWN state.
Solution:
To resolve this issue, restart the VMware management agents using the below procedure. Prior to starting, ensure that the Virtual machine startup/shutdown with host feature is disabled.
Restart Management agents in ESXi Using Direct Console User Interface (DCUI):
- Connect to the console of your ESXi host.
- Press F2 to customize the system.
- Log in as root.
- Use the Up/Down arrows to navigate to Troubleshooting Options > Restart Management Agents.
- Press Enter.
- Press F11 to restart the services.
- When the service restarts, press Enter.
- Press Esc to log out.
- On vCenter Server, restart the vCenter and Management Web services
Once the above procedure is completed, attempt the VPG move again.