Symptoms:
The Zerto Manager Service failed to start due to Zerto Virtual Manager log on account is using the "User domain account".
The below error messages are from Microsoft Windows Event Viewer - Application logs:
.NET:
Application: Zerto.Zvm.Service.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.UnauthorizedAccessException
Application:
Faulting application name: Zerto.Zvm.Service.exe, version: 7.5.30.57, time stamp: 0x5e2ee464
Faulting module name: KERNELBASE.dll, version: 10.0.17763.737, time stamp: 0x7416f3ae
Exception code: 0xe0434352
Fault offset: 0x0000000000039129
Faulting process id: 0x19f0
Faulting application start time: 0x01d5f1aba466596f
The below error messages are from Microsoft Windows Event Viewer - Application logs:
.NET:
Application: Zerto.Zvm.Service.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.UnauthorizedAccessException
Application:
Faulting application name: Zerto.Zvm.Service.exe, version: 7.5.30.57, time stamp: 0x5e2ee464
Faulting module name: KERNELBASE.dll, version: 10.0.17763.737, time stamp: 0x7416f3ae
Exception code: 0xe0434352
Fault offset: 0x0000000000039129
Faulting process id: 0x19f0
Faulting application start time: 0x01d5f1aba466596f
Cause:
The Local Security Policy on the ZVM server is not set up properly which is causing the Zerto Virtual Manager service not to start properly.
Solution:
To check the Local Security Policy is set up properly on the ZVM server:
1. Remote desktop into the ZVM server.
2. Launch Server Manager
3. In the Server Manager - click on Tools then Local Security Policy
4. In the Local Security Policy, check the two settings: 'Log on as a service' and 'Allow log on locally'. Make sure both settings have the correct user account listed, edit as required, then try to start the Zerto Virtual Manager service once more.