ymptoms:
- The vCenter account used to log in to the ZVM UI is assigned to more than one role in the vCenter server that the ZVM is configured to use.
- When attempting to execute a task in the ZVM UI, a customer may unexpectedly receive an error similar to:
You do not have the correct set of permissions for this task.
- One of the roles assigned to the account used to log in to the ZVM UI has different Zerto privileges than the other role(s) assigned.
Cause:
Zerto uses the vCenter server specified during installation for authentication and to validate a user can access and manage components of the Zerto site.
Zerto uses the effective role assigned by vSphere/vCenter when validating the permissions the account has to manage the Zerto site. Depending on which role vSphere assigns, the effective role may not include the Zerto privileges needed to execute a task in the ZVM UI.
Zerto uses the effective role assigned by vSphere/vCenter when validating the permissions the account has to manage the Zerto site. Depending on which role vSphere assigns, the effective role may not include the Zerto privileges needed to execute a task in the ZVM UI.
Solution:
Review all the roles assigned to the account used to log in to the ZVM UI and verify each role is assigned the same Zerto privileges.
-or-
Remove any role with less or different Zerto privileges from the account used to log on to the ZVM UI.