Symptoms

The error might be reported during backup.

Cause

the computer name or IP address has been changed on the backup source computer or it cannot be resolved from the DS-Client computer.

One more reason for this issue:

https://support.microsoft.com/en-ca/help/3040803/target-account-name-is-incorrect-error-when-a-domain-user-accesses-a-s

Workaround

Ensure that the backup source computer name can be resolved from the DS-Client computer (e.g. try to create in DS-User a file system set and place the string \\source-computer-name in the target server filed or expand Microsoft Windows Network and try to select the backup source computer from the servers list).


Check also the Microsoft KB:

https://support.microsoft.com/en-ca/help/3040803/target-account-name-is-incorrect-error-when-a-domain-user-accesses-a-s