Symptoms

The error might be reported when attempting to run DS-Client installation on top of an existing DS-Client deployment (e.g. to update DS-Client computer name after migrating DS-Client application and recovering the DS-Client databases).

Cause

A hotfix including a non-re-runable database patch was previously applied, for v13.3 DS-Client the installation expects the database number to be 319 or lower, for v14.0 DS-Client the installation expects the database number to be 326 or lower.

Workaround


connect with SQL tools to dsclient database and temporarily change(lower) the database number to match the base installed version, run the setup, change back(increase) the database number to the original value, then re-apply the most recent DS-Client hotfix for that particular version.

Detailed procedure:

1. Stop DS-Client service


2. Connect with SQL Tools to the SQL Server instance holding the DS-Client databases and run the query below on dsclient database in order to get the current database number:

select db_number from setup;

For v13.3 the db_number value would be 326 if the most recent hotfix was applied, while for v14.0 the db_number value would be 327 if the most recent hotfix was applied, just make a note of the value retrieved.


3. Lower the db_number accordingly to match a specific release, for v.13.3 run the query:

update setup set db_number=319;


for v14.0 run the query:

update setup set db_number=326;


4. Run the DS-Client installer corresponding to the version of the DS-Client that needs to be updated, in the last screen deselect the option 'Start DS-Client service';


5. Increase back the database number to the original value, for example for v.13.3 run the query:

update setup set db_number=326;


for v14.0 run the query:

update setup set db_number=327;


6. Re-apply the most recent DS-Client hotfix available for that particular Asigra version.


7. Start DS-Client service.