Challenge

                    


Failures occur during the File to tape or Backup to tape jobs. The jobname.log shows error messages similar to:

error: The request could not be performed because of an I/O device error
error: Tape fatal error.\nThe I/O bus was reset


                                            

Cause

                                                    


Depending on the type of connection, controller or library used, periodic status requests may be handled too slow and fill up the queue. As a result, Windows may try to recover by resetting the bus.


                                                                            

Solution

                                    


For all versions of Veeam B&R:

  1. Additionally you may need to increase StorPort timeouts by creating a "StorPort" key with entries for all tape devices. You can get DEVICEID & INSTANCE with the following PowerShell command:    
    gwmi -class win32_tapedrive
             
    • Location: KLM\System\CurrentControlSet\Enum\SCSI\DEVICEID\INSTANCE\Device Parameters\StorPort\
    • Type: DWORD
    • Name: BusyRetryCount
    • Value: 1000 (DEC)
               
    • Location: KLM\System\CurrentControlSet\Enum\SCSI\DEVICEID\INSTANCE\Device Parameters\StorPort\
    • Type: DWORD
    • Name: BusyPauseTime
    • Value: 1000 (DEC)
               
    • Location: KLM\System\CurrentControlSet\Enum\SCSI\DEVICEID\INSTANCE\Device Parameters\StorPort\
    • Type: DWORD
    • Name: BusyTimeoutCount
    • Value: 1000 (DEC)
               
  2.     
  3. Reboot the server, for settings to be applied

 


                                                   

More Information

                    

The following is additional settings specific to Veeam B&R v7.x:

  1. Increase the time between status requests by adding following registry entry, and restart the Veeam services:     
    • Location: HKLM\Software\Veeam\Veeam Backup and Replication
    • Type: DWORD
    • Name: TapeDeviceWatcherTimeoutSec
    • Value: 300