Symptoms

Vss backup reports the below error:
Access is denied. (\\ComputerName\C$\ProgramData\Microsoft\Crypto\RSA\MachineKeys)
The following 2 errors in Event Log:
C:\Windows\complusbackup\888335756\vsscontrol.exe Access is denied.
C:\Windows\complusbackup\888335755\sfcfiles.exe" -debug Access is denied.

Cause

Incorrect permissions on the folders reporting error.

Workaround

1. Reset permissions on that specific folder (C:\Users\All Users\Microsoft\Crypto\RSA\MachineKeys) & check the backup next time https://support.microsoft.com/en-gb/help/278381/default-permissions-for-the-machinekeys-folders
2. Enter the correct domain name in the 'From' field of the backup set credentials screen (even if it is not listed).
3.On the backup source computer go to Start > Settings > Control Panel > System and Security > Windows Firewall > Allow programs to communicate through Windows Firewall, tick "Remote Scheduled Task Management" , save the change.
4.Turnoff UAC and any AV to try the backup.
5. Add host entry for source server ip and name in the ds-client server host list.
6. Exclude this folder from virus scan or disable anti-virus.