Symptoms

When backing up Office 365, get the error "SharePoint Online: failed to backup the list item with the id (13874) under the list (Documents)  of the site (/personal/common_asigrainc_onmicrosoft_com). The error is : (The remote server returned an error: (404) Not Found.).", file confirmed to exist in OneDrive, but not being backed up by DS-Client.

Cause

There are certain characters not allowed for naming documents in SharePoint Online: " ? < > # % / \.", this feature (for special character support) was included by MS in 2017 and is anticipated to be integrated for our support in the future release.
To verify the file name you can connect to the OneDrive Site > On the top left corner, there is the 'SEARCH ONEDRIVE' field. Type the ID and search.

Workaround

- Rather then excluding this item, you can try to rename the file name and check the backup activity.
- There is another option to disallow this feature from the service side as explained in MS forums: https://docs.microsoft.com/en-us/sharepoint/dev/solution-guidance/supporting-and-in-file-and-folder-with-the-resourcepath-api Using the SharePoint Online Management Shell, you can run the following command to disable it: Set-SPOTenant -SpecialCharactersStateInFileFolderNames $Disallowed