Symptoms

DS-Client backup of Oracle server reports the following error:
ORA-12154: TNS: Could not resolve the connect identifier specified

Cause

This occurs if the Oracle Database Service Name has changed since this backup set was created. When you define an Oracle backup set, each backup item contains the Service Name as part of the path (e.g. an Oracle DB with the Service Name "orcl" might have backup items "orcl\SYSTEM" or "orcl\*"). If the Service Name is changed, DS-Client will fail to connect to the Oracle database with the ORA-12154 error.

Workaround

This is not likely to occur often (or at all), but in the event such a change is made, you must migrate the backup set in order to change the \item_name from the old Oracle Service Name to the new one.

To migrate the backup set:

1. Right-click the Oracle backup set and select "Migrate...". The Migrate Backup Set wizard appears.

2. Select the computer to backup. In this situation, this will be the same machine as the original backup set.

3. When you click "Next >", you are prompted to supply the Oracle Database credentials.
- Adjust the backup set's database credentials to use the new service name.

4. Follow the rest of the Wizard screens to re-specify the backup set items and complete the migration. Once migration is complete, try backing up again to verify you do not get the ORA-12154 error.

Another alternative is you can create an entirely new backup set and stop using the old one.