Symptoms:

Currently there are several product limitations which affect the usage of the JFLR feature.
Symptoms can be:

  • Failure to mount disk for file restore
  • Failure to extract requested file from already mounted disk
  • Failure to unmount a mounted disk after a file was restored


Cause:

Limitations in JFLR feature


Solution:

Before openeing a support case please check the following conditions:

  1. JFLR can only support restoration of files from file systems that the ZVM supports. Which means JFLR cannot support mounting "RAW" disks
  2. You can only recover files or folders from Windows machines. You cannot recover files or folders from Linux machines
  3. If the Windows virtual machine with files to be restored uses dynamic disks, files cannot be restored from these disks
  4. When the Zerto Virtual Manager is installed on a Hyper-V Generation 1 virtual machine, you can only mount disks for file level recovery from a Hyper-V generation 1 virtual machine
  5. When the Zerto Virtual Manager is installed on a Hyper-V Generation 2 virtual machine, you can mount disks for file level recovery from a Hyper-V generation 1 virtual machine and from all disks except for the boot disk (usually C:) from a Hyper-V generation 2 virtual machine
  6. JFLR currently cannot support mounting Windows Server 2012 disk formats when the ZVM is on a lower version like Windows Server 2008R2, although it will work the other way around
  7. JFLR currently cannot mount more than one GPT with the same ID. This can be caused by using the same OVF for all the replicated VMs
  8. JFLR cannot support VI client session due to the fact that it uses the browser download function therefore must be used in a session that's using HTML5 client
  9. When a large number of disks are mounted, when they are unmounted, some of the disks remain mounted and this is not reflected in the user interface
  10. You can only recover files or folders when an offsite backup is not running
  11. To restore files from a protected virtual machine when Role Based Access Control (RBAC) permissions are set in the Zerto Cloud Manager, your user must have both the "Manage VPGs" and "View Only" privileges set
  12. JFLR cannot mount disk of a machine that configured to use UEFI or Secure Boot
  13. JFLR cannot mount disks larger than 2 terabytes (provisioned size).


Affected Versions:

4.5 and greater


Hypervisor:

VMWare/Hyper-V