Symptoms

Following error is reported in the event log when backing up Office 365 SharePoint:
Failed to get the list item for list. The error message is: Unknown error 0x80131537


Cause

There are multiple causes for this error to be reported in an Office 365 SharePoint backup. In the debug log following error is reported:

1) CSharePointOnline:debugging message from C#: at System.DateTime.Parse(String s, IFormatProvider provider) at System.Convert.ToDateTime(String value)

2) CSharePointOnline:debugging message from C#: The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator.

Solution

1) For the system date time conversion error, the issue is due to failure of converting a string to a time stamp. We use Microsoft API to convert the string to data time, but this API needs to know the format of the string. For example, to convert 11/26/2015 to a date time type, you need to provide the format as dd/mm/yyyy. If you provide the format as mm/dd/yyyy, it will fail.

Parent sites and sub sites have different regional settings. Check the regional setting of the parent and sub site and if possible change it to the correct format. As how to check the regional settings of a site, please see following:

https://support.office.com/en-us/article/Change-regional-settings-for-a-site-e9e189c7-16e3-45d3-a090-770be6e83c1a

For above error if the issue still persists, you can apply DS-Client Hot Fix 7 for version 13.1 SP1.

2) For the error due to list exceeding the threshold which is 5000 items in SharePoint, you can refer to the following knowledge base in the "dsuser.pdf" documentation:
"Limitation: Backup of SharePoint lists with 5,000+ items not supported"
Microsoft SharePoint has a list view threshold of 5,000 items.
Please see Microsoft support article https://support.microsoft.com/en-us/kb/2759051.
DS-Client cannot back up lists that exceed this threshold. The following error message may appear in the event log when DS-Client attempts to backup a SharePoint list that contains more than 5,000 items: The number of items in this list exceeds the list view threshold, which is 5000 items. To avoid backup failure due to this limitation, split items from one list into multiple lists so that each list that needs to be backed up by DS-Client does not exceed 5,000 items.