Symptoms:

 

Starting with Zerto Virtual Replication (ZVR) 3.1, Zerto implemented a means for customers to update the list of Zerto-certified vSphere builds supported for Zerto Virtual Manager (ZVM) installations. This way, customers do not have to wait for the next official ZVR release for the new vSphere ESXi version to be supported.  Assuming the necessary connectivity is available between the customer ZVM and vCenter, this list will be updated automatically at midnight ZVM-time, following Zerto’s certification of a new ESXi version.  In the event that the necessary connectivity does not exist, the list of Zerto-certified ESXi versions supported for customer ZVM installations can be updated manually.  This article explains the necessary process.


Cause:

 

New ESXi releases


Solution:

In order to update the list of Zerto-certified ESXi versions, follow these steps:

  • Contact AssureStorSupport to ensure that the ESXi version you want to use is certified by Zerto.
  • Navigate to the Zerto Virtual Replication directory on the ZVM, based on the version of Zerto you are using: 3.1, 3.5, 4.0 – the default is C:Program Files(x86)ZertoZerto Virtual Replication. 4.5 – the default is C:Program FilesZertoZerto Virtual Replication
  • Locate the supported updates.txt file, and copy it to the desktop for a backup.
  • Edit the supported updates.txt file in the Zerto Virtual Replication directory, and add the necessary string, on a new line in sequence with the other strings, with the following syntax:ESX_<VersionNumberWithoutPeriod> <Update Number>

For example, for vSphere 5.1 Update 2, the string to be added is: ESX_51 2 Note that if the file already contains an ESX version string listed with the same version number, but a different update number, replace it with the new update. For example, if the version to be added is vSphere 5.5 Update 1, and ESX_55 0 is listed, replace it with ESX_55 1. Save the file. Access the Zerto GUI for the relevant site (If the Zerto GUI was already opened, please refresh the page). Click the Site Configuration "cog” (3.5 and earlier) or “menu” (4.X and later) button > "Advanced Settings" > "Compatibility Matrix". Verify that the new Zerto-certified ESXi version is listed. Notes: Do not to add any extra white spaces for the new entry in the supported_updates.txt file, as this file is very sensitive to white spaces. If a VRA has already been installed on a host with the new ESXi version, after the automated or manual change to the list of Zerto-certified ESXi versions, the VRA that previously showed a status of "Unsupported Version" will automatically enter a supported state. If any issues are encountered, please contact AssureStor Support.


Affected versions:
3.1Ux, 3.5Ux, 4.0Ux, 4.5Ux


Hypervisor:
VMware